summaryrefslogtreecommitdiffstats
path: root/ecmake/examples/hello/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ecmake/examples/hello/CMakeLists.txt')
-rw-r--r--ecmake/examples/hello/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/ecmake/examples/hello/CMakeLists.txt b/ecmake/examples/hello/CMakeLists.txt
new file mode 100644
index 0000000..caae503
--- /dev/null
+++ b/ecmake/examples/hello/CMakeLists.txt
@@ -0,0 +1,20 @@
+LIST(APPEND HELLO_WORLD_CC_SOURCES
+ main.c
+ )
+
+include_directories(
+ ${ELEMENTARY_INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}/lib
+ )
+
+add_executable(hello_world ${HELLO_WORLD_CC_SOURCES})
+
+get_target_property(ecmake_LIB_FILE ecmake LOCATION)
+target_link_libraries(hello_world
+ ${ELEMENTARY_LIBRARIES}
+ ${ecmake_LIB_FILE}
+ )
+
+add_dependencies(hello_world ecmake)
+
+add_test(Example_hello_world hello_world)