summaryrefslogtreecommitdiffstats
path: root/autofoo-efl/data/themes/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'autofoo-efl/data/themes/Makefile.am')
-rw-r--r--autofoo-efl/data/themes/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/autofoo-efl/data/themes/Makefile.am b/autofoo-efl/data/themes/Makefile.am
new file mode 100644
index 0000000..6125a54
--- /dev/null
+++ b/autofoo-efl/data/themes/Makefile.am
@@ -0,0 +1,23 @@
+MAINTAINERCLEANFILES = Makefile.in
+
+SUBDIRS = images
+
+EDJE_CC = @edje_cc@
+EDJE_FLAGS_VERBOSE_ =
+EDJE_FLAGS_VERBOSE_0 =
+EDJE_FLAGS_VERBOSE_1 = -v
+EDJE_FLAGS = $(EDJE_FLAGS_$(V)) -id $(top_srcdir)/data/themes/images -fd $(top_srcdir)/data/fonts
+
+filesdir = $(pkgdatadir)/themes
+files_DATA = \
+default.edj
+
+EXTRA_DIST = default.edc
+
+default.edj: Makefile default.edc
+ $(EDJE_CC) $(EDJE_FLAGS) \
+ $(top_srcdir)/data/themes/default.edc \
+ $(top_builddir)/data/themes/default.edj
+
+clean-local:
+ rm -f *.edj