summaryrefslogtreecommitdiffstats
path: root/ecmake/examples/hello/CMakeLists.txt
diff options
context:
space:
mode:
authorJérémy Zurcher <jeremy@asynk.ch>2012-04-13 23:03:55 +0200
committerJérémy Zurcher <jeremy@asynk.ch>2012-04-13 23:03:55 +0200
commit23929ded8ba244359e871e1d02ee1d05d060ea71 (patch)
tree0d22b1481f2259376ab3aa4d48f746ad76d8a3e5 /ecmake/examples/hello/CMakeLists.txt
parent3c54b36fa04a7c54bb685705397ce3eac707f956 (diff)
downloadskeletons-23929ded8ba244359e871e1d02ee1d05d060ea71.zip
skeletons-23929ded8ba244359e871e1d02ee1d05d060ea71.tar.gz
add ecmake, thanks a lot to eobj guys
Diffstat (limited to 'ecmake/examples/hello/CMakeLists.txt')
-rw-r--r--ecmake/examples/hello/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/ecmake/examples/hello/CMakeLists.txt b/ecmake/examples/hello/CMakeLists.txt
new file mode 100644
index 0000000..caae503
--- /dev/null
+++ b/ecmake/examples/hello/CMakeLists.txt
@@ -0,0 +1,20 @@
+LIST(APPEND HELLO_WORLD_CC_SOURCES
+ main.c
+ )
+
+include_directories(
+ ${ELEMENTARY_INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}/lib
+ )
+
+add_executable(hello_world ${HELLO_WORLD_CC_SOURCES})
+
+get_target_property(ecmake_LIB_FILE ecmake LOCATION)
+target_link_libraries(hello_world
+ ${ELEMENTARY_LIBRARIES}
+ ${ecmake_LIB_FILE}
+ )
+
+add_dependencies(hello_world ecmake)
+
+add_test(Example_hello_world hello_world)