summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 0000000..20b3e39
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,20 @@
+LIST(APPEND TESTS_CC_SOURCES
+ main.c
+ )
+
+include_directories(
+ ${EINA_INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}/src/include
+ )
+
+add_executable(tests ${TESTS_CC_SOURCES})
+
+get_target_property(eiotas_LIB_FILE eiotas LOCATION)
+target_link_libraries(tests
+ ${EINA_LIBRARIES}
+ ${eiotas_LIB_FILE}
+ )
+
+add_dependencies(tests eiotas)
+
+add_test(Example_tests tests)