summaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorJérémy Zurcher <jeremy@asynk.ch>2012-05-29 14:52:15 +0200
committerJérémy Zurcher <jeremy@asynk.ch>2012-05-29 14:52:15 +0200
commit3baf3d0553435a29773c75864e66f86af7e3fe4c (patch)
treeba240b38fa50ab65875298e785cdeae440c1e9fd /doc/CMakeLists.txt
parentb9c2581d70d76da143bfa55b12d5cc912b1b08df (diff)
downloadedoors-3baf3d0553435a29773c75864e66f86af7e3fe4c.zip
edoors-3baf3d0553435a29773c75864e66f86af7e3fe4c.tar.gz
enable doxygen usage
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
new file mode 100644
index 0000000..0906151
--- /dev/null
+++ b/doc/CMakeLists.txt
@@ -0,0 +1,7 @@
+include(UseDoxygen OPTIONAL)
+
+add_custom_target(__copy_img COMMAND ${CMAKE_COMMAND} -E copy_directory
+ ${CMAKE_CURRENT_SOURCE_DIR}/img/
+ ${CMAKE_CURRENT_BINARY_DIR}/html/)
+
+add_dependencies(doc __copy_img)