summaryrefslogtreecommitdiffstats
path: root/k8055gui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'k8055gui/CMakeLists.txt')
-rw-r--r--k8055gui/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/k8055gui/CMakeLists.txt b/k8055gui/CMakeLists.txt
new file mode 100644
index 0000000..e641518
--- /dev/null
+++ b/k8055gui/CMakeLists.txt
@@ -0,0 +1,19 @@
+
+ADD_EXECUTABLE(k8055gui WIN32 MACOSX_BUNDLE MyApp.cpp MyFrame.cpp )
+
+TARGET_LINK_LIBRARIES(k8055gui
+ k8055-${VERSION}
+ ${wxWidgets_LIBRARIES}
+)
+
+INCLUDE(${wxWidgets_USE_FILE})
+
+INCLUDE_DIRECTORIES(
+ ${CMAKE_SOURCE_DIR}
+ # ${wxWidgets_INCLUDE_DIRS}
+)
+
+ADD_DEPENDENCIES(k8055gui k8055-${VERSION})
+
+INSTALL(TARGETS k8055gui RUNTIME DESTINATION bin BUNDLE DESTINATION bin )
+